const regex = /\{\{\s*[Gg]tfs feed(?:\s*\|\s*(?:name\s*=\s*(?'name'[^|}]*)(?<!\s)|code\s*=\s*(?'code'[^|}]*)(?<!\s)|url\s*=\s*(?'url'[^|}]*)(?<!\s)|[^|}]*))*\}\}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\{\\{\\s*[Gg]tfs feed(?:\\s*\\|\\s*(?:name\\s*=\\s*(?\'name\'[^|}]*)(?<!\\s)|code\\s*=\\s*(?\'code\'[^|}]*)(?<!\\s)|url\\s*=\\s*(?\'url\'[^|}]*)(?<!\\s)|[^|}]*))*\\}\\}', 'gm')
const str = `{{gtfs feed | name = OVapi | code = nl-ovapi | operator = Stichting OpenGeo | url = https://gtfs.ovapi.nl/nl/gtfs-nl.zip}}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}