import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{\\{\\s*[Gg]tfs feed(?:\\s*\\|\\s*(?:name\\s*=\\s*(?'name'[^|\\}]*)(?<!\\s)|code\\s*=\\s*(?'code'[^|\\}]*)(?<!\\s)|url\\s*=\\s*(?'url'[^|\\}]*)(?<!\\s)|[^|\\}]*))*\\}\\}";
final String string = "{{gtfs feed | name = OVapi | code = nl-ovapi | operator = Stichting OpenGeo | url = https://gtfs.ovapi.nl/nl/gtfs-nl.zip}}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}