re = /\{\{\s*[Gg]tfs feed(?:\s*\|\s*(?:name\s*=\s*(?'name'[^|}]*)(?<!\s)|code\s*=\s*(?'code'[^|}]*)(?<!\s)|url\s*=\s*(?'url'[^|}]*)(?<!\s)|[^|}]*))*\}\}/m
str = '{{gtfs feed | name = OVapi | code = nl-ovapi | operator = Stichting OpenGeo | url = https://gtfs.ovapi.nl/nl/gtfs-nl.zip}}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end