using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:(?:\+?968|00968)\d{8}|[279]\d{7})$";
string input = @"22345678
72345678
92345678
12345678
+96822345678
0096822345678
96822345678
+96872345678
0096872345678
96827345678
+96829345678
0096892345678
96892345678
+96812345678
0096812345678
96812345678";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}