import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?:\\+?968|00968)\\d{8}|[279]\\d{7})$";
final String string = "22345678\n"
+ "72345678\n"
+ "92345678\n"
+ "12345678\n"
+ "+96822345678\n"
+ "0096822345678\n"
+ "96822345678\n"
+ "+96872345678\n"
+ "0096872345678\n"
+ "96827345678\n"
+ "+96829345678\n"
+ "0096892345678\n"
+ "96892345678\n"
+ "+96812345678\n"
+ "0096812345678\n"
+ "96812345678";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}