package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:(?:\+?968|00968)\d{8}|[279]\d{7})$`)
var str = `22345678
72345678
92345678
12345678
+96822345678
0096822345678
96822345678
+96872345678
0096872345678
96827345678
+96829345678
0096892345678
96892345678
+96812345678
0096812345678
96812345678`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}