// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:(?:\+?968|00968)\d{8}|[279]\d{7})$").unwrap();
let string = "22345678
72345678
92345678
12345678
+96822345678
0096822345678
96822345678
+96872345678
0096872345678
96827345678
+96829345678
0096892345678
96892345678
+96812345678
0096812345678
96812345678";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}