use strict;
my $str = '22345678
72345678
92345678
12345678
+96822345678
0096822345678
96822345678
+96872345678
0096872345678
96827345678
+96829345678
0096892345678
96892345678
+96812345678
0096812345678
96812345678';
my $regex = qr/^(?:(?:\+?968|00968)\d{8}|[279]\d{7})$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}