import Foundation
let pattern = #"^(?:(?:\+?968|00968)\d{8}|[279]\d{7})$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
22345678
72345678
92345678
12345678
+96822345678
0096822345678
96822345678
+96872345678
0096872345678
96827345678
+96829345678
0096892345678
96892345678
+96812345678
0096812345678
96812345678
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)