#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\w*_abcd)\s*(?: (abcd_\w*);?)+"
Local $sString = " thing: random1_abcd" & @CRLF & _
" abcd_n1p3; abcd_n2p1" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""random2_abcd" does not exist." & @CRLF & _
" thing: random3_abcd" & @CRLF & _
" abcd_n1p1; abcd_n2p3" & @CRLF & _
"" & @CRLF & _
" thing: random4_abcd" & @CRLF & _
" abcd_n1p3; abcd_n3p1; abcd_n2p7" & @CRLF & _
"" & @CRLF & _
" thing: random5_abcd" & @CRLF & _
" abcd_n4p2; abcd_n3p3; abcd_n6p7; abcd_n1p6" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")