re = /(\w*_abcd)\s*(?: (abcd_\w*);?)+/
str = ' thing: random1_abcd
abcd_n1p3; abcd_n2p1
"random2_abcd" does not exist.
thing: random3_abcd
abcd_n1p1; abcd_n2p3
thing: random4_abcd
abcd_n1p3; abcd_n3p1; abcd_n2p7
thing: random5_abcd
abcd_n4p2; abcd_n3p3; abcd_n6p7; abcd_n1p6
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end