// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\w*_abcd)\s*(?: (abcd_\w*);?)+").unwrap();
let string = " thing: random1_abcd
abcd_n1p3; abcd_n2p1
\"random2_abcd\" does not exist.
thing: random3_abcd
abcd_n1p1; abcd_n2p3
thing: random4_abcd
abcd_n1p3; abcd_n3p1; abcd_n2p7
thing: random5_abcd
abcd_n4p2; abcd_n3p3; abcd_n6p7; abcd_n1p6
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}