# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\w*_abcd)\s*(?: (abcd_\w*);?)+"
test_str = (" thing: random1_abcd\n"
" abcd_n1p3; abcd_n2p1\n\n\n"
"\"random2_abcd\" does not exist.\n"
" thing: random3_abcd\n"
" abcd_n1p1; abcd_n2p3\n\n"
" thing: random4_abcd\n"
" abcd_n1p3; abcd_n3p1; abcd_n2p7\n\n"
" thing: random5_abcd\n"
" abcd_n4p2; abcd_n3p3; abcd_n6p7; abcd_n1p6\n\n\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.