using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(numberPinyin"":\s*"".*)(v)(.*)""";
string substitution = @"\1ü\3";
string input = @"['{""russian"": ""женщина"", ""english"": ""woman, v"",""numberPinyin"": ""nv3"",""typeOfChar"":""character"",""typeOfTranslating"":""original""}',
'{""chinese"": ""弯竖左钩"", ""russian"": ""вогнутая с крюком влево"", ""english"": ""concave with left hook"",""numberPinyin"": ""eav"",""typeOfChar"":""stroke"",""typeOfTranslating"":""byStrokes""}',
'{""chinese"": ""弯竖右钩"", ""russian"": ""вогнутая с крюком вправо"", ""english"": ""concave with right hook"",""numberPinyin"": ""vm2"",""typeOfChar"":""stroke"",""typeOfTranslating"":""byStrokes""}']";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}