// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(numberPinyin":\s*".*)(v)(.*)""#).unwrap();
let string = "['{\"russian\": \"женщина\", \"english\": \"woman, v\",\"numberPinyin\": \"nv3\",\"typeOfChar\":\"character\",\"typeOfTranslating\":\"original\"}',
'{\"chinese\": \"弯竖左钩\", \"russian\": \"вогнутая с крюком влево\", \"english\": \"concave with left hook\",\"numberPinyin\": \"eav\",\"typeOfChar\":\"stroke\",\"typeOfTranslating\":\"byStrokes\"}',
'{\"chinese\": \"弯竖右钩\", \"russian\": \"вогнутая с крюком вправо\", \"english\": \"concave with right hook\",\"numberPinyin\": \"vm2\",\"typeOfChar\":\"stroke\",\"typeOfTranslating\":\"byStrokes\"}']";
let substitution = "\\1ü\\3";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}