#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)zoom_[a-zA-Z1-9][a-zA-Z1-9][a-zA-Z1-9][a-zA-Z1-9][a-zA-Z1-9][a-zA-Z1-9]"
Local $sString = "zoom_asol2j" & @CRLF & _
"zoomea" & @CRLF & _
"zoom_sikwna" & @CRLF & _
"zoom_2j38sd"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")