// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)zoom_[a-zA-Z1-9][a-zA-Z1-9][a-zA-Z1-9][a-zA-Z1-9][a-zA-Z1-9][a-zA-Z1-9]").unwrap();
let string = "zoom_asol2j
zoomea
zoom_sikwna
zoom_2j38sd";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}