# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/((\\\()((?!(\\\()|(\\\))).)*(\\\)))/<math>$1<\/math>/gm;t' <<< "y = x2 or \(x = \sqrt{y}\) . For all \(y \geq 0\), x is defined. Thus, y is set of all non-negative and real number. Hence, range is \(y \geq 0\) or [0, ∞)."