import Foundation
let pattern = #"((\\\()((?!(\\\()|(\\\))).)*(\\\)))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"y = x2 or \(x = \sqrt{y}\) . For all \(y \geq 0\), x is defined. Thus, y is set of all non-negative and real number. Hence, range is \(y \geq 0\) or [0, ∞)."#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<math>$1</math>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)