$re = '/((\\\\\()((?!(\\\\\()|(\\\\\))).)*(\\\\\)))/m';
$str = 'y = x2 or \\(x = \\sqrt{y}\\) . For all \\(y \\geq 0\\), x is defined. Thus, y is set of all non-negative and real number. Hence, range is \\(y \\geq 0\\) or [0, ∞).';
$subst = "<math>$1</math>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;