# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"((\\\()((?!(\\\()|(\\\))).)*(\\\)))"
test_str = "y = x2 or \\(x = \\sqrt{y}\\) . For all \\(y \\geq 0\\), x is defined. Thus, y is set of all non-negative and real number. Hence, range is \\(y \\geq 0\\) or [0, ∞)."
subst = "<math>$1</math>"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.