use strict;
my $str = 'y = x2 or \\(x = \\sqrt{y}\\) . For all \\(y \\geq 0\\), x is defined. Thus, y is set of all non-negative and real number. Hence, range is \\(y \\geq 0\\) or [0, ∞).';
my $regex = qr/((\\\()((?!(\\\()|(\\\))).)*(\\\)))/mp;
my $subst = '<math>$1</math>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";