#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b(?!\w*(\w)(\w)(?!\1)\2(?!\2)\1)\w+\b"
Local $sString = "Words that it must exclude:" & @CRLF & _
"abba // (ab/ba pair)" & @CRLF & _
"smelled // (el/le pair)" & @CRLF & _
"trillion // (il/li pair)" & @CRLF & _
"test" & @CRLF & _
"" & @CRLF & _
"trillion" & @CRLF & _
"" & @CRLF & _
"trillllion"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")