$re = '/\b(?!\w*(\w)(\w)(?!\1)\2(?!\2)\1)\w+\b/m';
$str = 'Words that it must exclude:
abba // (ab/ba pair)
smelled // (el/le pair)
trillion // (il/li pair)
test
trillion
trillllion';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);