const regex = /\b(?!\w*(\w)(\w)(?!\1)\2(?!\2)\1)\w+\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?!\\w*(\\w)(\\w)(?!\\1)\\2(?!\\2)\\1)\\w+\\b', 'gm')
const str = `Words that it must exclude:
abba // (ab/ba pair)
smelled // (el/le pair)
trillion // (il/li pair)
test
trillion
trillllion`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}