import re
regex = re.compile(r"\b(?!\w*(\w)(\w)(?!\1)\2(?!\2)\1)\w+\b", flags=re.MULTILINE)
test_str = ("Words that it must exclude:\n"
"abba // (ab/ba pair)\n"
"smelled // (el/le pair)\n"
"trillion // (il/li pair)\n"
"test\n\n"
"trillion\n\n"
"trillllion")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")