import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?!\\w*(\\w)(\\w)(?!\\1)\\2(?!\\2)\\1)\\w+\\b";
final String string = "Words that it must exclude:\n"
+ "abba // (ab/ba pair)\n"
+ "smelled // (el/le pair)\n"
+ "trillion // (il/li pair)\n"
+ "test\n\n"
+ "trillion\n\n"
+ "trillllion";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}