re = /\b(?!\w*(\w)(\w)(?!\1)\2(?!\2)\1)\w+\b/m
str = 'Words that it must exclude:
abba // (ab/ba pair)
smelled // (el/le pair)
trillion // (il/li pair)
test
trillion
trillllion'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end