package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\.ofType\(core\.([A-Z_]*.)\)`)
var str = `.ofType(core.REJECT_PENNG_USER)
.ofType(core.REJECT_PDING_USER)
.ofType(core.REJT_PENDING_USER)
.ofType(core.REJET_PENDING_USER)
.ofType(core.REJECT_PENDISER)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}