const regex = /\.ofType\(core\.([A-Z_]*.)\)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\.ofType\\(core\\.([A-Z_]*.)\\)', 'gm')
const str = `.ofType(core.REJECT_PENNG_USER)
.ofType(core.REJECT_PDING_USER)
.ofType(core.REJT_PENDING_USER)
.ofType(core.REJET_PENDING_USER)
.ofType(core.REJECT_PENDISER)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}