// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\.ofType\(core\.([A-Z_]*.)\)").unwrap();
let string = ".ofType(core.REJECT_PENNG_USER)
.ofType(core.REJECT_PDING_USER)
.ofType(core.REJT_PENDING_USER)
.ofType(core.REJET_PENDING_USER)
.ofType(core.REJECT_PENDISER)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}