using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?s)(?<!dislike.*?)string1(?!.*?dislike)";
string substitution = @"<p>replaced</p>";
string input = @"This text contains both the word ""string1""
and the word ""dislik"".
Remove in order for the regex to match.";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}