import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?s)(?<!dislike.*?)string1(?!.*?dislike)";
final String string = "This text contains both the word \"string1\"\n"
+ "and the word \"dislik\".\n"
+ "Remove in order for the regex to match.";
final String subst = "<p>replaced</p>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}