$re = '/(?s)(?<!dislike.*?)string1(?!.*?dislike)/i';
$str = 'This text contains both the word "string1"
and the word "dislik".
Remove in order for the regex to match.';
$subst = "<p>replaced</p>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;