re = /(?s)(?<!dislike.*?)string1(?!.*?dislike)/i
str = 'This text contains both the word "string1"
and the word "dislik".
Remove in order for the regex to match.'
subst = '<p>replaced</p>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result