const regex = new RegExp('(?s)(?<!dislike.*?)string1(?!.*?dislike)', 'gi')
const str = `This text contains both the word "string1"
and the word "dislik".
Remove in order for the regex to match.`;
const subst = `<p>replaced</p>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);