import re
regex = re.compile(r"(?s)(?<!dislike.*?)string1(?!.*?dislike)", flags=re.IGNORECASE)
test_str = ("This text contains both the word \"string1\"\n"
"and the word \"dislik\".\n"
"Remove in order for the regex to match.")
subst = "<p>replaced</p>"
result = regex.sub(subst, test_str)
if result:
print(result)