using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*({\""ABC\"":\"".*?\""}).*";
string substitution = @"$1";
string input = @"{""ABC"":""Hello""},{""DEF"":""World""},{""GHI"":""!!!""}";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}