re = /.*({\"ABC\":\".*?\"}).*/m
str = '{"ABC":"Hello"},{"DEF":"World"},{"GHI":"!!!"}'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result