use strict;
my $str = '{"ABC":"Hello"},{"DEF":"World"},{"GHI":"!!!"}';
my $regex = qr/.*({\"ABC\":\".*?\"}).*/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";