using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^\W\d_])|.";
string substitution = @"\1";
string input = @"ABCŁąć1-2!Абв3§4“5def”";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}