$re = '/([^\W\d_])|./m';
$str = 'ABCŁąć1-2!Абв3§4“5def”';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;