import re
regex = re.compile(r"([^\W\d_])|.", flags=re.MULTILINE)
test_str = "ABCŁąć1-2!Абв3§4“5def”"
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)