const regex = new RegExp('([^\\W\\d_])|.', 'gm')
const str = `ABCŁąć1-2!Абв3§4“5def”`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);