# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(THIS)\b\s*(.*)/$2 $1/;t' <<< "THIS the rest of the string"