use strict;
my $str = 'THIS the rest of the string';
my $regex = qr/^(THIS)\b\s*(.*)/p;
my $subst = '$2 $1';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";