import re
regex = re.compile(r"^(THIS)\b\s*(.*)")
test_str = "THIS the rest of the string"
subst = "$2 $1"
result = regex.sub(subst, test_str, count=1)
if result:
print(result)