const regex = /^(THIS)\b\s*(.*)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(THIS)\\b\\s*(.*)', '')
const str = `THIS the rest of the string`;
const subst = `$2 $1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);