$re = '/^(THIS)\b\s*(.*)/';
$str = 'THIS the rest of the string';
$subst = "$2 $1";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;