re = /^(THIS)\b\s*(.*)/
str = 'THIS the rest of the string'
subst = '$2 $1'
result = str.sub(re, subst)
# Print the result of the substitution
puts result